Reply
Highlighted
New Member
Posts: 1
Registered: ‎01-09-2018

Server Taking too long to start

Ok, so in an attempt to prune files to relieve some of the space taken up with ace files i came across an issue where i couldnt get the mongo.exe to sync with the mongodb. so in attempt i removed the ace files manually (taking a backup of coarse and tried to re run the mfi controller and now im facing this issue where the server takes too long to start. i will attach the log files to this post and if anyone has an idea to a solution i would very much appreciate it! 

 

 

 

Wed Jan 10 15:23:06.194 [initandlisten] MongoDB starting : pid=11860 port=37017 dbpath=C:\Users\Administrator\Ubiquiti mFi\data\db 64-bit host=Autoserver2
Wed Jan 10 15:23:06.194 [initandlisten] db version v2.4.6
Wed Jan 10 15:23:06.194 [initandlisten] git version: b9925db5eac369d77a3a5f5d98a145eaaacd9673
Wed Jan 10 15:23:06.194 [initandlisten] build info: windows sys.getwindowsversion(major=6, minor=1, build=7601, platform=2, service_pack='Service Pack 1') BOOST_LIB_VERSION=1_49
Wed Jan 10 15:23:06.194 [initandlisten] allocator: system
Wed Jan 10 15:23:06.194 [initandlisten] options: { bind_ip: "127.0.0.1", dbpath: "C:\Users\Administrator\Ubiquiti mFi\data\db", logappend: true, logpath: "logs/mongod.log", nohttpinterface: true, port: 37017 }
Wed Jan 10 15:23:06.209 [initandlisten] journal dir=C:\Users\Administrator\Ubiquiti mFi\data\db\journal
Wed Jan 10 15:23:06.209 [initandlisten] recover : no journal files present, no recovery needed
Wed Jan 10 15:23:06.303 [initandlisten] ****
Wed Jan 10 15:23:06.303 [initandlisten] ****
Wed Jan 10 15:23:06.303 [initandlisten] need to upgrade database ace with pdfile version 4.21, new version: 4.5
Wed Jan 10 15:23:06.303 [initandlisten] Not upgrading, exiting
Wed Jan 10 15:23:06.303 [initandlisten] run --upgrade to upgrade dbs, then start again
Wed Jan 10 15:23:06.303 [initandlisten] ****
Wed Jan 10 15:23:06.303 dbexit:
Wed Jan 10 15:23:06.303 [initandlisten] shutdown: going to close listening sockets...
Wed Jan 10 15:23:06.303 [initandlisten] shutdown: going to flush diaglog...
Wed Jan 10 15:23:06.303 [initandlisten] shutdown: going to close sockets...
Wed Jan 10 15:23:06.303 [initandlisten] shutdown: waiting for fs preallocator...
Wed Jan 10 15:23:06.303 [initandlisten] shutdown: lock for final commit...
Wed Jan 10 15:23:06.303 [initandlisten] shutdown: final commit...
Wed Jan 10 15:23:06.319 [initandlisten] shutdown: closing all files...
Wed Jan 10 15:23:06.319 [initandlisten] closeAllFiles() finished
Wed Jan 10 15:23:06.319 [initandlisten] journalCleanup...
Wed Jan 10 15:23:06.319 [initandlisten] removeJournalFiles
Wed Jan 10 15:23:06.319 [initandlisten] shutdown: removing fs lock...
Wed Jan 10 15:23:06.319 dbexit: really exiting now

 

 

 

 

 

 

 

Regular Member
Posts: 551
Registered: ‎04-24-2014
Kudos: 214
Solutions: 11

Re: Server Taking too long to start

If you have a backup in one of the folders is a .ini thats the config you can set to run it as a new install and it will purge the bad db and let you load your backup.

 

im at work and cant get your the exact location.

Matt W
Reply