EdgeRouter X: Slow throughput


  • O
    Custom Avatar

    Noobie here breaking stuff.

    Modem->ERX->end devices

    I noticed my throughput dropping signficantly a week ago. I am unable to get above 5mbps while connected to the edge router. If I were to bypass the edge router and connect directly to the modem I will get 100+ mbps. I don't know what I did to muck it up as it was working fine a week ago, any ideas or input will be greatly appreciated.

    thank you!

    firewall {                                                                      
        all-ping enable                                                             
        broadcast-ping disable                                                      
        ipv6-receive-redirects disable                                              
        ipv6-src-route disable                                                      
        ip-src-route disable                                                        
        log-martians enable                                                         
        name WAN_IN {                                                               
            default-action drop                                                     
            description "WAN to internal"                                           
            rule 10 {                                                               
                action accept                                                       
                description "Allow established/related"                             
                state {                                                             
                    established enable                                              
                    related enable                                                  
                }                                                                   
            }                                                                       
            rule 20 {                                                               
                action drop                                                         
                description "Drop invalid state"                                    
                state {                                                             
                    invalid enable                                                  
                }
            }                                                                       
        }                                                                           
        name WAN_LOCAL {                                                            
            default-action drop                                                     
            description "WAN to router"                                             
            rule 10 {                                                               
                action accept                                                       
                description "Allow established/related"                             
                state {                                                             
                    established enable                                              
                    related enable                                                  
                }                                                                   
            }                                                                       
            rule 20 {                                                               
                action drop                                                         
                description "Drop invalid state"                                    
                state {                                                             
                    invalid enable                                                  
                }                                                                   
            }                                                                       
        }                                                                           
        receive-redirects disable                                                   
        send-redirects enable
        source-validation disable                                                   
        syn-cookies enable                                                          
    }                                                                               
    interfaces {                                                                    
        ethernet eth0 {                                                             
            address dhcp                                                            
            description Internet                                                    
            duplex full                                                             
            firewall {                                                              
                in {                                                                
                    name WAN_IN                                                     
                }                                                                   
                local {                                                             
                    name WAN_LOCAL                                                  
                }                                                                   
            }                                                                       
            speed 100                                                               
        }                                                                           
        ethernet eth1 {                                                             
            address 192.168.1.1/24                                                  
            description Laptop                                                      
            duplex full                                                             
            speed 100
        }                                                                           
        ethernet eth2 {                                                             
            address 10.10.10.1/24                                                   
            description Desktop                                                     
            duplex full                                                             
            speed 100                                                               
        }                                                                           
        ethernet eth3 {                                                             
            address 192.168.3.1/24                                                  
            description Xbox                                                        
            duplex full                                                             
            speed 100                                                               
        }                                                                           
        ethernet eth4 {                                                             
            description AP                                                          
            duplex full                                                             
            poe {                                                                   
                output off                                                          
            }                                                                       
            speed 100                                                               
        }                                                                           
        loopback lo {                                                               
        }
        switch switch0 {                                                            
            address 192.168.2.1/24                                                  
            description Local                                                       
            mtu 1500                                                                
            switch-port {                                                           
                interface eth4 {                                                    
                }                                                                   
                vlan-aware disable                                                  
            }                                                                       
        }                                                                           
    }                                                                               
    service {                                                                       
        dhcp-server {                                                               
            disabled false                                                          
            hostfile-update disable                                                 
            shared-network-name Eth4 {                                              
                authoritative disable                                               
                subnet 192.168.2.0/24 {                                             
                    default-router 192.168.2.1                                      
                    dns-server 192.168.2.1                                          
                    lease 86400                                                     
                    start 192.168.2.38 {                                            
                        stop 192.168.2.243
                    }                                                               
                }                                                                   
            }                                                                       
            shared-network-name LAN1 {                                              
                authoritative disable                                               
                subnet 192.168.1.0/24 {                                             
                    default-router 192.168.1.1                                      
                    dns-server 192.168.1.1                                          
                    lease 86400                                                     
                    start 192.168.1.38 {                                            
                        stop 192.168.1.38                                           
                    }                                                               
                }                                                                   
            }                                                                       
            shared-network-name LAN3 {                                              
                authoritative disable                                               
                subnet 192.168.3.0/24 {                                             
                    default-router 192.168.3.1                                      
                    dns-server 192.168.3.1                                          
                    lease 86400                                                     
                    start 192.168.3.38 {                                            
                        stop 192.168.3.243                                          
                    }
                }                                                                   
            }                                                                       
            shared-network-name Server {                                            
                authoritative disable                                               
                subnet 10.10.10.0/24 {                                              
                    default-router 10.10.10.1                                       
                    dns-server 10.10.10.1                                           
                    lease 86400                                                     
                    start 10.10.10.38 {                                             
                        stop 10.10.10.243                                           
                    }                                                               
                }                                                                   
            }                                                                       
            use-dnsmasq disable                                                     
        }                                                                           
        dns {                                                                       
            dynamic {                                                               
                interface eth0 {                                                    
                    service custom-noip {                                           
                        host-name cyberatric.hopto.org                              
                        login cyberatric                                            
                        password ****************                                   
                        protocol noip
                        server dynupdate.no-ip.com                                  
                    }                                                               
                    web dyndns                                                      
                }                                                                   
            }                                                                       
            forwarding {                                                            
                cache-size 150                                                      
                listen-on eth1                                                      
                listen-on eth3                                                      
                listen-on eth2                                                      
                listen-on switch0                                                   
            }                                                                       
        }                                                                           
        gui {                                                                       
            http-port 80                                                            
            https-port 443                                                          
            older-ciphers enable                                                    
        }                                                                           
        nat {                                                                       
            rule 5010 {                                                             
                description "masquerade for WAN"                                    
                outbound-interface eth0                                             
                type masquerade
            }                                                                       
        }                                                                           
        ssh {                                                                       
            port 22                                                                 
            protocol-version v2                                                     
        }                                                                           
        upnp {                                                                      
            listen-on eth2 {                                                        
                outbound-interface eth0                                             
            }                                                                       
        }                                                                           
        upnp2 {                                                                     
            listen-on eth3                                                          
            listen-on eth4                                                          
            listen-on eth2                                                          
            nat-pmp enable                                                          
            secure-mode enable                                                      
            wan eth0                                                                
        }                                                                           
    }                                                                               
    system {                                                                        
        host-name ubnt                                                              
        login {
            user ubnt {                                                             
                authentication {                                                    
                    encrypted-password ****************                             
                }                                                                   
                level admin                                                         
            }                                                                       
        }                                                                           
        ntp {                                                                       
            server 0.ubnt.pool.ntp.org {                                            
            }                                                                       
            server 1.ubnt.pool.ntp.org {                                            
            }                                                                       
            server 2.ubnt.pool.ntp.org {                                            
            }                                                                       
            server 3.ubnt.pool.ntp.org {                                            
            }                                                                       
        }                                                                           
        syslog {                                                                    
            global {                                                                
                facility all {                                                      
                    level notice                                                    
                }                                                                   
                facility protocols {
                    level debug                                                     
                }                                                                   
            }                                                                       
        }                                                                           
        time-zone UTC                                                               
    } 
    

  • Try, via SSH, or even via the cli (upper right corner)

    configure

    set system offload hwnat enable
    commit
    save

    exit
    But why the interfaces are set to 100 and not in 'Auto' ?
    Cheers,
    jonatha


  • O
    Custom Avatar

    I'll give that a shot!

    I have always been told in networking class when to never let it decide on it's own to manually set it to full duplex. Is that the wrong thing to do?


  • O
    Custom Avatar

    I ran the commands, saved and rebooted still under 6mbps, any other suggestions by any chance?

    Edit:set everything to auto negotiate and it's back to normal, my mind is blown right now


  • Beta Testers

    redfive wrote:

    But why the interfaces are set to 100 and not in 'Auto' ?
    Cheers,
    jonatha


    – very Excellent Catch


  • S
    Beta Testers

    ocularcoder wrote:

    I have always been told in networking class when to never let it decide on it's own to manually set it to full duplex. Is that the wrong thing to do?


    Twenty years ago I might have agreed with the sentiment of setting the speed and duplex, but we're now in the 21st century and today I think that approach is wrong. In my experience, when using 10/100/1000 Mbps capable NICs and switches, auto-negotiation is the better option.

    In the past some vendors may not have supported auto-negotiation, but it's been a mandatory requirement of the IEEE 802.3 standard since at least 2005. From Clause 40.5.1 of the IEEE 802.3 2005 standard:

    "40.5.1 Support for Auto-Negotiation

    All 1000BASE-T PHYs shall provide support for Auto-Negotiation (Clause 28) and shall be capable of operating as MASTER or SLAVE."

    The fact auto-negotiation is mandatory means it usually works as it should, otherwise vendors are not able to claim compliance to the standard and interoperability with other devices.

    If you must configure duplex, then the important point is to configure it the same on both link partners. If you configure it on one device and not the other, you have a situation where the device supporting auto-negotiation believes the link partner is not auto-negotiation capable, and falls back to using half duplex. I've not found a statement in any standard that says failing to half duplex is the required behaviour, but every device I've ever worked with operates this way.

    And of course, when you have one link partner operating full duplex, and the other operating half duplex, you have a duplex mismatch. See Duplex Mismatch for an explanation of the situation you were in and why performance is so poor.

    Regards


Posts 6Views 0
Log in to reply

Looks like your connection to Ubiquiti Networks Community was lost, please wait while we try to reconnect.